Scheduled for October 10, 2024 at 6:00 AM – 1:00 PM
Affects
Chelan County Fiber
Under maintenance from 6:00 AM to 1:00 PM
Updates
Completed
October 10, 2024 at 1:00 PM
Completed
October 10, 2024 at 1:00 PM
Maintenance has completed successfully
In progress
October 10, 2024 at 6:00 AM
In progress
October 10, 2024 at 6:00 AM
Maintenance is now in progress
Planned
October 10, 2024 at 6:00 AM
Planned
October 10, 2024 at 6:00 AM
Chelan County PUD will be performing emergency maintenance on their network from 11:00 PM PST on October 9th, 2024, to 6:00 AM PST on October 10th, 2024. Impacted customers have already been notified by email. If you have not received an email, your area will not be affected. Thank you for your understanding.